Cam V3 grabbing local WAN endpoint IP

For clarification, the cams connect directly to the ASUS (edge) router. Nothing too complicated where they’re concerned.

Now that I’ve thought of it for a few minutes, and given I can’t access both my router and the cam in question, if there is an OS rule about duplicate MACs on my network, it’s likely that they are being dropped to null bin (null0), not passed to any device/MAC.

Okay I at least finally understand where you were going with the clone theory.

Just reading on using MAC cloning in dd-wrt routers, you need to either manually enter the MAC you want to use on the router or clone it from the PC you are using. So my impression is that you would need to manually enter a camera MAC on the router, which isn’t something I would expect.

Yep, and that’s why I’ve stated I have ZERO reason to knowingly and deliberately clone ANY MAC address on my router. If I discover that’s what’s going on, it will remain a mystery why, but I can attribute some of the smaller mysteries in my life to a night of imbibing…and yet I can’t imagine a scenario where I might have been in that condition, copied or selected a MAC address from one of my cameras out of a list, and just happened to paste it into a MAC clone setting…then deliberately saved the changes! :grinning:

Hold on a minute. Come to think about it, I’m pretty sure I have some router syslogs somewhere. I should go see if I can find one or more, and see what they might uncover!

OK, mystery solved! My router is in fact cloning the MAC address of one of my cams, and apparently it’s been doing it since at least July 2021 (earliest syslog I have, but more recent syslogs show the same relevant entries). That loosely correlates to about when my intermittent re-connectivity issues started, but it doesn’t explain why I my router usually re-connects, and I can see the cam of the duplicated MAC when it does connect. From a routing perspective it doesn’t seem like a router would be able to discern where to send packets if Layer 2 addresses are in conflict. Nevertheless, I know what’s going on even if I have no clue how it happened (because I had to have manually set the cloning…and why on earth would I do that???). That said, the last line of the syslog excerpt below says it all, and the MAC address indicated is the Wyze MAC address my ISP tech told me he was seeing yesterday.

Jul 31 19:00:13 smbd[367]: [2015/07/31 19:00:13.552917, 0] lib/util_sock.c:667(open_socket_in)
Jul 31 19:00:13 smbd[367]: bind failed on port 445 socket_addr =
Jul 31 19:00:13 smbd[367]: Error = Address already in use
Jul 31 19:00:13 smbd[367]: [2015/07/31 19:00:13.554132, 0] smbd/server.c:628(smbd_open_one_socket)
Jul 31 19:00:13 smbd[367]: smbd_open_once_socket: open_socket_in: Address already in use
Jul 31 19:00:13 smbd[367]: [2015/07/31 19:00:13.555069, 0] smbd/server.c:628(smbd_open_one_socket)
Jul 31 19:00:13 smbd[367]: smbd_open_once_socket: open_socket_in: Address already in use
Jul 31 19:00:13 wan: mac clone: [wan0_hwaddr] == [7C:78:B2:37:B0:06]


Okay that kind of makes sense. Thanks for the update. Your cloned MAC was wreaking havoc with the ARP table in the router’s switch, causing inconsistent paths for the data. Which is still just little weird, since it’s the router’s own feature. Maybe they assumed you would remove the original device after cloning.

OK, my WAN connection resolved itself (it has before) sometime this morning, and I gained access to my router and I can see my cameras. Found the MAC cloning setting on my router, and sure enough my ‘Cam2’ MAC address was present. I have ABSOLUTELY NO IDEA why I would have ever done that, but apparently I did as early as July 2021!!! Mind boggling…

Yes, it is absolutely assumed the cloned device would be removed (or never to be running concurrently), and I can only imagine ASUS hadn’t anticipated a cloned device would ever be on the same network as the router. MAC cloning is typically (always?) used to supplant a new router/device in place of an old one on the customer end of a WAN circuit whenever an ISP binds a customer’s MAC address to same (if just to buy some time until the ISP can be called to setup the new router’s MAC address). One of the respondents via the link you provided summed it up pretty nicely: Two active MAC addresses on the same network will result in inconsistent packet delivery without some type of port security. Also noted was that delivery status for each device involved will “flap on and off” which might help to explain why I sometimes gain access to my router after and outage, and sometimes not; however, I’m still a bit unsure why – when the router had established a proper connection to the ISP – the router and the camera in question worked flawlessly for weeks on end until there was another router reboot…despite the fact they’re sharing the same MAC address. Another bit of research for another time, but as it stands, I’m crossing my fingers my re-connection issues have been resolved.

1 Like

Well, they won’t really be resolved until you get back there, remove that setting, and let the router’s own MAC speak for itself, assuming the ISP allows it. I imagine you don’t have the appetite for trying to initiate that change remotely…

1 Like

No, I deleted the cloned MAC and saved, and everything is as it should be on my router. ISP doesn’t match MACs on the WAN connection, so I’m good to go.

1 Like