Bulbs turn on by themselves

Intermittent Power Loss Anyone that experiences random power loss definitely should contact your local power company. The biggest cause of intermittent power loss is tree branches growing over power lines. I had to call my local power company before to correct this issue in the past. After they cut the branches off of the power lines the intermittent power problem stopped.
This definitely would cause the Wyze bulbs to turn on even after a slight power loss

However, so far I haven’t had a problem with my bulbs randomly turning on.


No power loss here. My bulbs are on a smart UPS(always on, pure sinewave). Also that would not explain why the other 2 did not turn on and these two did.

In your case, you got the power covered by the smart UPS. :+1:
On the other hand, not sure why some are experiencing this issue and others are not.

However, I mentioned this so if anyone has intermittent power loss, they can be aware that this will cause your bulbs to turn on.

With me, i have the 4 bulbs… and only 1 is doing it… and in this case, its 2 bulbs in the same fixture ( ceiling fan ) …and swapping them around didn’t change anything.

I will say its been a few days now and hasn’t happened… so maybe cured it self :slight_smile:

It is so weird. I am going to run wireshark tonight when I go to bed and see if it’s getting some errant call to turn on. That or a fimrware bug is the only thing I can scome up with…

The controller (esp-wroom02) is robust and reliable so I doubt it’s to do with the hardware.

Spoke to soon… got home from work… turned fan on… lights come on… wait a while and ask Alexa to turn them off… they go off.

~15 minutes later the 1 problem child bulb came back on.
Instantly got on the app right away and was showing status ON. Meaning the WIFI was already established and hadn’t lost state i’d think.

I have two ceiling fans in one room with four bulbs each. I’m having the same issue. One set will come on randomly, other times both. Even times where one bulb turns on and the others stay off. I don’t believe it’s a power issue or the results wouldn’t be so random. It’s almost to the point I’m going to have to remove them and put my original led bulbs back in and ask for a refund.

Sit tight for a week or so if you can. I am going to do some board level troubleshooting on this issue. I hope to at least verify if its hardware or software. If its software, they will probalby update the firmware.

If its hardware, then yeah, returning is your best bet. I expect to have something figured out this weekend.

Did you have any luck? Trying to decide where I need to go from here. Thanks!

I kind of did. I ran wireshark all weekend and found that the bulbs are losing their IP address for some reason. I pulled off the firmware and started disassembling it…

I am 90% sure its a firmware problem. I had no power dips and no issues with my router or fiber modem.

What I suspect is that either the firmware itself has a bug or when the initial firmware update happened it did not load right. I also passed on the RouteThis results to the support folks at Wyze.

I am not finished digging through the firmware but I am more confident its a software rather than hardware issue.

If they didn’t fill the dang housing with silicon potting goo, it would make this a lot easier… I hope to be finished digging through the firmware in another day. I pulled it off a good bulb(one I have not had problems with) and the other 3 bulbs that I am having trouble with. Im hoping to find a glaring difference between them.

1 Like

Ok, good. I guess I’ll hold onto them then. Thank you for all the work.

This is happening to me as well so I’m following.

I talked to one of their support folks and they told me they have escalated it.

So far I have run wireshark and seen what looks to be a webserver reset on the bulb end. I am not 100% sure but it seems that all is fine until some point where the bulb starts asking the router for a new ip address. The thing is, it already had an IP Address.

I decided to sacrifice my properly acting bulb and removed the internals completely. I then partly assembled one of the bulbs that are acting up. I have pulled the contents of both eproms and will compare the contents and see if there is any differences between the 2.

My semi educated guess is that when the firmware initially updated, it was corrupted on the miss-behaving bulbs. I hope that comparing the properly acting bulb to the other will show the error in the firmware. If not, I will try loading the firmware from the good bulb into the bad bulb and see if it changes the behavior.

I do wish Wyze had a little more turn around on the support. I have only been getting one reply a day. They are helpful and polite but the response time is a bit poor in my opinion. My day job involves offering support for technical issues (not smart bulb related unfortunately) and we respond many times until its resolved rather than once a day. That is my only real complaint…oh and the bulbs coming on in the middle of the night… Wife is not happy about that.

More news

No reply from support yesterday and no mention of my request for firmware. However I did dump the eproms of both a good light and a bad light. In comparison to each other, the good light shows data in spots where the bad light does not.

I also found a link buried inside the dump to the firmware for the ota update. I then downloaded and compared that bin file and it looks more like the good bulb dump.

I did not have time to try and load the bin file yet but I hope to have time tonight. Only problem is I have to dig out the bulb board and connect to the board. I am going to investigate using WiFi since that’s what others need to do.

Once I do this, I will let you all know.

Not a bug.
It’s the uneducated artificial intelligence random on/off feature.

1 Like

You mean the new A.U… Artificial Unintellegence.

There is going to be a movie released later this year starring a much older Haley Joel Osment.

1 Like

I found more info. Dayjob has been in the way of finishing what I suspect will work but it’s Friday now

I hope to update you all this weekend.

My sniffer shows it losing but re-acquiring a new IP almost immediately after the loss :man_shrugging:

That is what I keep seeing too. I was able to load the proper firmware using a USB adapter that I use for ESP8266 but you have to remove the led array and dig out some of the rubber potting to get to the pins.

I’m trying to figure out how to load it OTA. I downloaded the SDK from espressif and setup the VM they recommend. So I’m hoping to figure it out in a few more days.

pictures? I was wanting to do the same and almost did with one until I found thaqt in setup if i just waited an extra few seconds for the bulb to fully connect to wifi (it seemed slower then the others) that it then worked as expected. anyway it’s heavy and as an electronics geek I am curious.