Beta Testing for Wyze Cam v3 RTSP Firmware Now Available!

I just reset it and made sure it is on my desired ssid but it displays that ip address that is out of range. I do have firmware installed

using Bluestacks/TinyCam i’ve been able to connect to my cams using Cloud and RTSP/TCP (using default Web & RTSP port numbers), but i can’t figure out how to use RTSP/UDP…how is the setup for this protocol different from RTSP/TCP?

Here is what I did … and it worked!
setup the Wyze Cam 3 as normal
put a 8 gb flash card in the camera
let the camera format the drive
removed the flash drive and copied the new firmware to it
unplugged the camera
put the flash drive in, held down the button
blue/purple light came on after a few seconds and stayed on

after a while , the camera restarted and showed up working in the app
settings/advanced settings, RTSP showed up!
created a user/password and let the camera generate the url
copied the url and pasted it in chrome browser on my computer
let VLC open the link

Regarding RTSP work the v3 cams and Hikvision NVRs, why do you suspect it’s an audio issue?

The v3s show a black window on Hikvision NVRs via RTSP, but v2s are fine.

I’d like to try to get this to work, but stuck.

I loaded the beta f/w on my v3 and am trying to get it to work with Frigate/Home Assistant, However, the image freezes frequently. When not frozen, any motion causes the entire stream to blur and lag severely. The camera is sitting directly new to my access point and has no issues connecting to the LAN (speed/signal) or internet (firewall). I have tried accessing the camera directly via VLC to eliminate Frigate, HA, and the hardware its running on, and have the same issues.

Note: I have read this entire thread and have seen this mentioned a couple times but the conversation always seems to come back to the issues with BlueIris. Would like to see more regarding issues/using this with other NVR softwares.

What does your m ffmpeg options look like? I have the firmware on a v3 not very close to access point and works fine with frigate/HA. Also, what fps are you using in frigate.yaml? I run 5 fps @ 1920x1080

  global_args: -hide_banner -loglevel fatal
    record: -f segment -segment_time 60 -segment_format mp4 -reset_timestamps 1 -strftime 1 -c copy -an

I can confirm that all three of my v3’s have severe issues with live audio both on the stable and beta releases of firmware. The audio on my v2’s on the same network works great. This is occurring on both the stable and beta firmware for months with many updates since. I hope a solution is provided soon as the audio appears to be the only short-coming with the v3’s.

Severe is an understatement.

All my v2 RTSP cams work 100% with my Hikvision NVR, yet my v3 RTSP cams won’t show an image at all. I am trying to debug, but have yet to determine root cause. All other software seems to stream v3 RTSP (VLC, ffmpeg, Surveillance Station, VSplayer), yet a Hikvision NVR won’t display the image.

I suspect it may be due to the audio stream, or the lack of WebRTC, but who knows. I would really like the v3 RTSP firmware to work with my NVR, but am forced to use docker-wyze-bridge for the time being.

I have the same issue of a black screen on the Hikvision.

Works on VLC

Same for me, works with nearly every other player with the exception of Hikvision NVRs (whether OEM or Hik branded). When I say works, I mean that an image is displayed with other players.

I have been trying to troubleshoot for some time now, with no luck. It would be nice if Wyze were to chime in and possibly help with this issue, as it’s limiting me from upgrading all my v2 cams to v3.

wyze needs to make it onvif compliant, just having a rtsp address creates more problems then need it to work with blueiris v5.4.6.3. locally but from outside my network i need to use blueiris server for the wan side. cumbersome to use that on an android phone when just want to take a quick look at my cams, currently i have 3 v3 cams and a few generics but generics have onvif protocols so i can use different rtsp port so apps like ip cam viewer by chou for android work flawlessly when coming from the wan side

Why can’t you code different NAT ports at your router to reach the stock RTSP port on multiple Wyzecams? (E.g., router port 61554 goes to camera one port 554, router port 62554 goes to camera two port 554, etc.)

afaik u would have to have different internal ports but we cant change the wyze rtsp port, router can only direct external wan request to one internal port so devices need their own internal port. on lan it doesnt matter because we are using the lan ip address to connect to the 554 port.
external port can be whatever but it needs to be directed to the correct internal port by router. u cant have the same internal port directed to multiple devices that use same port when coming from the wan side.
this is how port forwarding works and as far as i know thats true unless someone proves otherwise

Yeah, no, it’s fine and easy to do with any consumer grade router. Edit: okay, I’ll hedge and say “most”.

using asus ac86u, above average pro consumer router. not a newb to networking, but only one specific internal port per device for port forwarding, u cant have external address going to same internal port for different devices. unless someone proves otherwise

With RTSP working “well enough” I now have a Camera Page display-able from Home Assistant. Each camera runs it’s own feed through ffmpeg. Home Assistant with DuckDNS and LetsEncrypt provide secusre access for off-site viewing. One port open for Home Assistant, nothing else.

1 Like

i seemed to have proven myself wrong, my old asus ac66 didnt have an option for wan internal ip target, ac86u does. still a pia to work with android apps because no web port or onvif support.
but i can use the blueiris server to view the cams remotely on android, dont think bluiris has a android app to do this so i use the android browser to log in the server. just needed an app to quickly view the cams. btw works well on blueiris but i have not tested the audio function as of yet

Are you using stock Wyze RTSP firmware or the docker wyze bridge?

They do:

Not free but works well.

Agree re ONVIF. Or at least some more control over ports, etc., when running RTSP.

Just the stock RTSP firmware

With my Amcrest cameras (native RTSP support):

  • Continuous (on camera) microSD card recording (5MP)
  • Home Assistant records motion events (on RPi server) for 30 seconds (2MP) no cool down period required
  • HA sever copy is copied to a PC server daily
  • HA server copies are deleted, when I feel like it (actually haven’t deleted any yet )
  • Free Cam Plus ?? a bit more fuss

If your tinkering with Home Assistant, I see no advantage to Wyze. If tinkering is not fun for you then Wyze Cam Plus-ity Plus Plus maybe the way to go.
Nothing wrong with an NVR either, but I’m too cheap :wink: