Battery Cam Pro not uploading videos (Cam Plus)

I purchased and installed a new Battery Cam Pro yesterday, and I can’t get it to upload a single video. It uploads still photos OK if I remove it from Cam Plus, but any events generated immediately show “Failed to upload” when I try to play them.

I’ve tried changing from 5GHz to 2.4GHz - no difference. It’s currently literally sitting on the shelf directly next to my router, and I still haven’t gotten a single video to work.

I see the firmware update was only released a couple of days ago - are others having a similar issue with the update?

I’ll try to bump this once - is no one else experiencing this issue? I even bought a new camera to see if it was a hardware issue, but I got the same result. Does anyone have Cam Plus working properly with a Battery Cam Pro on the latest firmware?

Support has been…slow…to put it generously.

Mine are working fine with latest firmware and Cam Plus.

1 Like

Thanks - appreciate the confirmation at least. I assume you’ve had them on Cam Plus since before the latest firmware update? The only thing I can think of is that there’s some bug in the linking process that was introduced recently, but it doesn’t appear that I can rollback the firmware to the earlier version to see if that fixes it (according to Support anyway).

It works fine if I unlink it from Cam Plus and just do photos, but I have literally not gotten a single video (in a few dozen attempts) to upload, and this is with two separate devices sitting on the same shelf as my router. Super frustrating.

1 Like

Yes, I’ve always had mine on Cam Plus. It’s running the latest production firmware version 1.3.20.1993. It’s definitely working well capturing events, but sometimes misses tags, especially person:

Maybe your settings need adjusting? This is what I have mine set to. Set sensitivity to 5 max to use both PIR and radar:

If you don’t think it’s a settings issue, try powercycling your cam. Disconnect from power if it’s plugged in (USB or solar panel), remove the battery, wait a minute, reinsert battery and make sure it starts up properly and connects to your WiFi.

1 Like

Yeah, definitely not a settings issue, and I’ve power cycled a half dozen times when working through this with Support. The events show up in the Events log and in the camera, but nothing will play.


Support has log files and screenshots, so I’m just waiting on next steps. (It’s been a few days now, so I suspect there isn’t an obvious answer.)

1 Like

When you try to view the same event by going to Wyze app Home > Events > your BCP event, do you receive the same “Failed to upload” error or does event viewing for your cam work from the Events tab?

The “Filed to upload” error is from the Events list. When I go directly to the camera’s interface, that’s when I get the “Loading Event…” screen (nothing else happens).

After easily 10 hours of troubleshooting and trying everything that I could possibly think of to fix this, I took it to a friend’s place, and it worked instantly as soon as I hooked up to their WiFi.

I literally haven’t gotten a single video to upload at home even when I’ve had it directly next to my router (photos work fine), so the only thing left I can think of is that there’s some weird incompatibility with how Cam Plus uploads work and how my CenturyLink B4000CG router works.

So before I just give up and return this thing, has anyone had a similar issue with any of their cameras and figured out any router settings that could possibly the issue? I’ve tried:

  1. WPA/WPA2/WPA3
  2. 2.4GHz/5GHz
  3. CenturyLink auto DNS vs. Google’s DNS (8.8.8.8)
  4. Forcing it to a new internal IP address

Thanks for any ideas!

I’m having the same issue. I have Centurylink as well, but a google nest system. SO frustrating.

i know their android app is buggy and they do not respond to tickets, try dsable orientation lock and try again.
or try on ipad

A user has shown a workaround, but I cannot get my MTU on my modem to go above 1500.

Wyze Battery Cam Pro Issues - Cameras - Wyze Forum