App freezes when hitting Air Purifier "manual" button

The whole app freezes when you go to the Air Purifier > Manual > click anything in here > APP FREEZES.

This started happening with the last (or possibly prior) app update.

Only reason I care about this is that I can’t schedule the speed of the thing within “rules” in the first place…If I could, I wouldn’t use the “manual” button half the time…

Instead of all this, I just go over to the damn thing and hit buttons on it physically…

I just tested mine with both iOS and Android’s and cannot reproduce.

Can you provide the following:

  • Are you using Android or iOS
  • What App Version are you using
  • What is the Firmware of your Air Purifier

Can you also provide what you have tried? For example:

  • Have you removed power from your Air purifier and the 10 seconds later, connected it again
  • Have you tried Clearing Cache from within the app and the restarting your Phone or tablet
  • Have you tried both iOS and Android?

Any information would be appreciated.

1 Like

iOS 16.6.1
wyze 2.45.5 (4)
purifier 1.0.13.2 says it’s up to date
app clear cache fails.
removed power for well over 15 minutes. nothing.
phone shut down, restart. nothing.
everything else on the phone works normally. probably 100 apps on here…
ain’t nuthing else for me to try here. been going on for at least 2 weeks I think…

Thanks for the info. I also signed up to Beta Test the App and firmware. Here is what I have for iOS

iOS Version: 17.0.2
App: 2.46.0 (2)
Firmware: 1.0.14.1

You can signup to beta test the app and firmware by going here for the app ( Become a Beta Tester – Wyze Labs, Inc) and then start the app and go to Account > About > Beta Program Then Choose Edit and select the devices you want the Beta Firmware for.

@SlabSlayer @IEatBeans @R.Good @carverofchoice , do any of you have the Air purifier with the Version @chomskyknows has? Need someone to test to see if the device hangs when selecting Manual Options.

1 Like

Sorry, I have the 2.46 beta app on iOS Testflight and don’t have this problem. No crashing here. I can’t check for the previous version though.

1 Like

Sorry, no air purifier here (cough, cough).

2 Likes

Have you tried force-killing the app? Restarting the phone doesn’t accomplish the same things as just killing an app.

I have an iPhone and iPad, and neither are having that issue,

1 Like

of course i force quit the app. that’s all you can do. You hit the manual button, then hit anything else and it’s frozen. I restarted the phone because Wyze dude up there asked me to. It was pointless step. did it. doesn’t do anything.

Just tried it again, hitting every other button in the Air Purifier area works fine. Just not “manual” - you hit that you, you might as well force quit immediately because you’re effed at that point. App will freeze. If it matters, it also makes you hit the “SAVE” or “CANCEL” button twice, then it freezes. Obviously having to hit the save or cancel button more than 1 time is also an error.

Sorry for the delayed response @spamoni and @chomskyknows

I am on iOS 16.6.1
Wyze App version 2.46.0 (2) Beta
Both of my Wyze Air Purifiers are on FW 1.0.14.1.

No App crashing issues on my side when managing the device.

1 Like

no one that has responded is using my verison of the app nor the purifier and my versions of everything are general release and 100% up to date. if that tells me anything, it tells me the app and/or firmware is/are bad (for the air purifier “manual” button only). most people probably won’t notice this because they’ll never hit that button. i don’t even want to hit it in the first place, but scheduling is lackluster in the app, which forces me to hit it, which now doesn’t even work…

I just went and loaded the Production Wyze App onto my iPhone for you:

  • Wyze App version 2.45.5 (4)

I have 3 Wyze air purifiers. I selected the Air Purifier>Manual> changed the speed> Save

Everything worked perfectly fine, no freezing. I repeated this several times, trying each spread and timer setting on multiple Air Purifiers. I never had a single crash.

However, I am using Air Purifier Firmware 1.0.14.1 Which it seems is a Beta Firmware that was launched back in January to improve connectivity. I don’t know why it never launched to public production, but it seems like the firmware is the main difference here.

If I were in your position, I would consider enrolling my Air Purifiers to receive beta firmware updates and see if it will let you update to the 1.0.14.1 firmware that is working for some of the rest of us.

Other than that, we can hope that someone else with iOS with the Air Purifier production firmware will chime in to either confirm that they are having the same problem or that it is working for them. I am not sure offhand who has one that stays on production firmware and app versions though, but you could report this to Support so they can log it. That’s probably what I would suggest doing at this point.

1 Like

iOS - 17.03 (iPad), 14.8 (iPhone)
Wyze - 2.45.5 (4)
Purifier - 1.0.13.2

Never had this issue.

BTW, Wyze made it possible that Alexa routines can set manual fan speeds for the Purifier, even though Wyze’s own app won’t do it. I also couldn’t find any support for it in Google Home, and it doesn’t seem like Apple HomeKit