Alexa no longer displaying Wyze Cam video (Fire Tablet HD 10 - Show Mode)

This was working last week and then suddenly stopped. Appears others are also seeing this but I have not seen it reported in the community.

When asking Alexa, “Alexa, show me the kid’s room.” Alexa responds with, “your Alexa enabled device does not currently support that”

No cameras work. I have tried disabling and re-enabling the Wyze skill in Alexa but the problem persists. I also noticed a difference in settings/options within the Alexa app, specifically that the “Announcement” settings have disappeared. It may or may not be related.

1 Like

I’m not too sure, but this sounds like it may be an issue with Amazon. I am guessing this because it’s not a “device not responding” or “connection failed” message. Have you tried any other brand of cameras with it? If so, did it work?

A bunch of people have been complaining that some or all of their cameras won’t do Alexa announcements. This is just one:

1 Like

I am having the same problem, but I don’t think it is an Amazon issue. This happened after Amazon updated the Fire HD10 a few week ago, If it was all Amazon I would think that none of my cameras would work, but Pan Cam still does. On the Alexa dashboard I can view the Pan Cam image, that still works, but the V2 cameras do not work. I think this is a Wyze issue with the V2 Camera and maybe needing an update hopefully and not having to buy all new V3 cameras. I don’t have any V3 cameras, so I don’t know if they are still supported. Is anybody else having this problem? I can only confirm that my Pan Cam is still working.

1 Like

No, as noted, it can be some or all. It is undetermined as to the root cause but it is entirely possible the fault lies with Amazon.

Has anyone found a solution to this yet?


Unfortunately, no. For what it’s worth, my new Cam v3 works just fine. Cam v2s and Cam Pans do not. I have tried just about everything but nothing has worked.

1 Like

My cam pan works, but my V2 cameras no longer work. Sounds like the V2 cameras need an update. Guess we will see if Wyze updates them to work, or we need to buy new V3 cameras. If the second is true, then I am done with Wyze.

1 Like

Turns out Wyze is working on it. Simply using the non-beta app and renaming cameras has worked for some.

Today, I can’t see any of my V2 and V3 cameras via Echo Show or fire tv. It was all working last night. Today I got a message that my two week trial camplus ended (did not participate) for the v3, That probably killed what I had. Now I can only view with their phone app which has bugs.

Any new updates on this subject?
I keep in getting error message from Alexa saying your device doesn’t currently support that.
Using device device dashboard on my fire hd8 tablet. Version 2 wyze cams and even wyze cam outdoor.


It’s been months now. They went one and two at a time, but in lucky to get 2 of 10 cameras to taos on any fire device. I have 3 tablets and 2 sticks. Once upon a time they all worked on all. Seriously kicking wyze in the cons column, which they are unfortunately racking up at an alarming rate. Seems like for every 1 thing they get right or release, it costs 3+ features or other. Really sucks cuz u have been with them since just about the beginning and own almost every device from pre release.

Have you had any luck with a solution yet? mine is now 100% of camera’s with identical alexa messages, whereas before i had assumed it was done intentionally to phase out the v2 (and possibly pan cam as well) because the timing perfectly coincided with the release of the v3’s.

No luck, Wyze never got back to me with a solution. Either Wyze wants us to buy never cameras and spend more money or it is Amazon, that is no longer supporting. Either way It most likely comes down to money, someone wants more of it. I have stopped buying any more Wyze products.

Oh well :zzz:
So much for that.