Adding sensor shows black screen

I’ve had wyze things for a few years.

Just recently I’ve been having a problem adding a new contact sensor. It only happens on my Samsung A5 cell phone. No problems on other devices.
The phone has android 8.0.0, Samsung experience 9.0. up to date as far as I know.
I deleted later apps I installed to no avail.

I click the + sign on the home screen. I select add a new contact sensor. The screen goes black. That’s it. I can add everything else.

Any thoughts, ideas, suggestions.

Just checking in for possible answers to my problem.
It only happens on my Samsung cell phone. I did a factory reset, installed the latest Wyze app, yet problem persists.

It only happens when I try to add a contact sensor. No problems adding anything else.

Suggestions, ideas?


I am having the same problem. I have a new Internet provider and tried to reconfigure all my devices. The Wyze sensors won’t work and trying to add them in the Wyze app results in a black screen. I also have a Samsung phone, but I don’t think that’s the problem.

Hi all — I’m glad to see I’m not the only one afflicted with this problem.

I had the same issue and have found a work-around described below.

Background —

  • When trying to add an Entry Sensor v2 from the App’s “Home” screen
    (Home → “+” to add a device → “Add Device” → “Sensors” → “Wyze Entry Sensor v2” or “Wyze Contact Sensor”)
    The screen on my phone goes dark, showing only the battery status (and whether or not the phone is charging). Upon hitting the home button, or the “Open apps” button, the Wyze app could be accessed, but it apparently starts a new session (like the earlier session had crashed or been closed.)
    • Phone & App Environment —
      • Samsung Galaxy S7
      • OS: Android Version 8.0.0
      • Wyze App v2.30.0 (130)
        The issue described above, first observed in mid-March, had continued even through the following update procedure…
        • From the Wyze App, the Cache was cleared.
        • A “Force Stop” was issued within the Apps section of the phone’s “Settings”
        • The Wyze App was uninstalled
        • The phone was restarted
        • The latest version of the Wyze App was installed from the Play Store
        • I signed-into the newly installed version of the App.
    • The problem appears to be unique to Contact Sensors and Entry Sensors. There’s no problem adding motion sensors, Wyze Cam v3, etc. when starting at the
      Home Screen → “Add Device”…

Work Around —

  • From the Wyze App “Home” screen
  • From the listing of Devices and Groups of Devices, Select “Wyze Sense Hub”
    • Select the “+” sign at the top right (next to the “Settings” icon) to add a device
      • From the “Add Device” screen, select Wyze Entry Sensor v2
        The step-by-step procedure to add an Entry Sensor v2 opens up and proceeds normally.

Since all of us have Samsung phones I suspect there’s a bug in the App that’s unique to Samsung hardware, but trying to add a device starting at the Wyze Sense Hub seems to bypass the bug and allow the device addition to proceed.

Hope this helps…

I have the same phone as you, the Samsung S7, Your workaround is fine, but only if you are using v2 sensors. The ohter workaround for those sensors is, if you have it, use home monitoring. You would go to Add Home Monitoring, Then click on the Home Monitoring Settings button right at the bottom, Select Environment, and then you will be able to add new sensors.
There is no workaround for the original v1 sensors.
You may be right about the problem lying with the app for Samsung. Wfhen I spoke to the Wyze support person, I asked him to look at his app and see if the bug affected him. His app was fine but, at the time, I wasn’t thinking that it would be different on different phones, so I didn’t ask him what phone he was using.
Interestingly, I have another Samsung phone that had an older version of the Wyze app, so I tried it. It didn’t give me a black screen, but ultimately I wasn’t able to pair the Wyze sensors, probably because the app was so old. When I turned off the phone and turned it back on again, the Wyzw app got updated to the latest version, complete with black screen.
I have logged the problem with Wyze, but haven’t received any response and they haven’t updated the app or the firmware yet.