About Wyze Robot Vacuum Firmware 1.6.126

Funny, I can see the update available for a fraction of second and it goes away. I don’t think the beta version is available to all the beta testers. Have opened a ticket but no response yet.

1 Like

There’s another thread by a Wyze developer in the forums (can’t remember where, it’s not in the Beta section), posted a week ago with progress update (video and images).

Apparently the mapping isn’t in a wide group beta. It’ll supposedly be rolling out to the main beta users “in a few weeks.”

I suspect (as this is common with development) they have a smaller subgroup of users that have proven themselves good testers (file reports, give accurate feedback, etc.) that gets the major feature development betas before everyone else.

1 Like

I cannot get a firmware update past 1.6.113. My Wyze robot vacuum is under the list of beta items.

I am running the Wyze app for IOS version 2.22.16.

Please help.

I don’t understand how they choose who gets the updates. I am currently on 1.6.130

It’s likely automated. You’re in the group getting the beta right now as .130 is higher than the .126 build everyone has been asking about.

1 Like

See my prior post above your post.

This is the thread the developers discuss this update: Wyze Robot Vacuum - The upcoming Multi-floor Mapping update is even better! - #7 by Illumination

1 Like

I am .113 not .130.

Any info on when this update will be released publicly?

My prior post above your post.

This one: About Wyze Robot Vacuum Firmware 1.6.126 - #61 by KyleK29

Any updates on this being released publicly?

My home is only one floor, and I can’t get it to clean that properly, so I can’t imagine what kind of chaos ensues if you have more than one floor to deal with.
Until you guys can fix the mapping so that it works reliably, you really should enable a stupid simple “spot cleaning” feature that allows you to put the vacuum down next to an area you want it to clean, and it just cleans around itself. No fancy mapping required, as it doesn’t need to know what room it’s in or where it is in relation to the charging station. Just set it down, activate the feature, it zips around for a few minutes, and it’s done. This would relieve my frustration when I’m unable to get it to clean an area that needs it but can never get there due to buggy mapping. Even better would be to allow me to pinpoint an area on the map in the app, and the vacuum goes to that spot and cleans (not the entire room…the area you need it cleaned) - but that would require functional mapping, which leads me back to the pick-it-up-and-put-it-down technique.

What issues are you having with the mapping / cleaning? Curious as I used to have issues, but they seemed to have cleared.

Hi Tom, I’m not sure why you have directed your complaint to me as I am a Wyze customer… and a WRV owner too.

The good news is that I generally agree with your complaint that the mapping didn’t work well in the beginning. However, my beta testing later releases indicates a great deal of progress has been made on 1.6.173. I think you’ll be much happier in the near future.

Like lots of folks here, I’m eagerly awaiting multi-floor support. Anyone have any insight on when the new software version will be generally available?

After much waiting I finally saw the prompt to get the firmware update. Interestingly I was prompted a couple weeks ago, but wasn’t home and hit cancel. Upon arriving home went to check the update and there was still no option again. So this morning I checked and i was prompted. It’s updating now. So I’m wondering if there is a bug in the logic that determines if there is an update available.

The update is 1.6.173 and has now completed. Yippee!

It is very strange behavior indeed.

Actually no bug in the process. There were a lot of reported issues which prompted Wyze to remove the FW update for a period of time. They just recently released the firmware again. From the looks of things, they corrected the installation issue individuals were experiencing in the past.

I was prompted to do a recent update and it bricked my robot vac. Wyze sent me a new one. The power button would just flash but never restart or turn off. We tried to reboot but nothing.

Great to hear they’re starting to roll out the update. I haven’t gotten any prompts on mine yet. Still on 1.6.113 and the Update Firmware screen doesn’t show any available updates. I’m on the 2.24.23 Android app. Is there a way to pull the firmware manually?

Edit: Looks like the new firmware is still in beta. I didn’t see mention of new firmware in the 2.24 release notes. https://support.wyze.com/hc/en-us/articles/360024852172-Release-Notes

it is a beta FW release for the Vacuum. you can get it if you subscribe to the Beta Firmware as well.


A little more information. If you are not in the Beta Program, you would need to sign-up for the Beta Program by going here: Become a Beta Tester – Wyze

Once you are signed up, you will have Beta Program located in Account / About area. Click on Beta Program then Edit in the top right and select the Beta Firmware you would like to test or see. Understand, this is beta firmware and can or will have problems.

1 Like

For what it’s worth, I got the upgrade option allowing me to access 1.6.173 for my second WRV at or near the same time you did.

I’ll assume they are just throttling the release levels to better manage the collateral damage. Trying to figure out who are “the chosen ones” is likely a fool’s errand.

So far the functionality of 1.6.173 makes the WRV very usable for me. But I don’t have the courage to drop it off my network and rejoin since I don’t know if that issue was addressed – apparently related to an iOS update on my SE2020 iPhone given that was what I narrowed it down to after a couple months of painful testing.

Technology is great when it works.